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1 简介 

PCAN-Diag FD 是一款用于 CAN 总线通信诊断的手持式诊断工具。可以

基于协议层诊断 CAN2.0 和 CAN FD 报文，也可以利用示波器功能和测量功能

实现物理层测试。  

示波器功能用于 CAN 总线上的信号曲线进行质量评估。CAN_H 和 CAN_L

使用独立的测量通道采样，采样频率达 100MHz。基于采集的信号曲线，

PCAN-Diag FD 可以解码 CAN 报文，并图形化显示报文的相关信息。  
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在协议层面上， CAN 报文通信数据流显示列表中，也可以加载数据库

（如 dbc，sym）文件，将十六进制的报文解析为具体的物理量，如温度，速

度，压力等。  

为了进一步的分析，Tracer 记录功能可记录 CAN 报文。PCAN-Diag FD

可发送 CAN 报文，支持单条报文或者一序列报文发送到 CAN 总线上；另外，

记录下来的 CAN 报文也通过 PCAN-Diag FD 回放到总线上，所有协议层的功

能都适用于 CAN2.0 和 CAN FD。 

新的 CAN FD 标准 (CAN with Flexible Data Rate) 主要特征是更高的数

据传输带宽。每个 CAN FD 帧最多可包含 64 个数据字节（代替目前的 8 位），

可用最快 12Mbit/s 比特率进行传输。CAN FD 向下兼容 CAN 2.0 A/B 标准。

可以在现有 CAN 网络中使用 CAN FD 节点。但是，在这种情况下，CAN FD

扩展并不适用。 

PCAN-Diag FD 带有一个按钮和四个功能键，操作方式简单。 该设备可由

外部供电，也可由内部电池供电，内部电池在外部供电的时候会自动充电。使

用可选的充电方式，可以加快充电过程。 

留意：本手册适用于固件版本为 1.4 的设备。 

1.1 技术参数 

硬件特点 

 高速 CAN 连接（ISO 11898-2）  

 兼容 CAN2.0A/B 和 CAN FD 标准 

 支持 ISO 标准和非 ISO 标准的 CAN FD 

 CAN FD 数据域（最大 64 字节）的传输速度，从 25kbit/s 到最高
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12Mbit/s 

 CAN 波特率 20Kbit/s—1 Mbit/s 

 Microchip CAN 收发器 MCP2558FD 

 九针 D-Sub 连接头（符合 CiA® 303-1) 

 屏幕 800 X 480 像素分辨率 

 根据功能和设备方向进行纵向或横向显示  

 通过微型 HDMI 接口（DVI 信号 800x600 像素）在外部显示器上显示  

 通过内部可充电电池或外部电源供电（低电压插座） 

 即使在运行期间，也可以通过外部电源对电池进行充电  

 内部存储卡用于保存工程，连接到电脑时也可用作 USB 大容量储存设备  

 通过一个按钮和四个功能键操作设备  

 工作温度：0-50°C（32-122°F） 

 

软件特点 

 在物理层和协议层上分析 CAN 和 CAN FD 网络  

 从预设列表或多选用户定义值中选择波特率 

 基于固定值列表自动检测波特率 

 可切换成只听模式  

 可选择静默启动功能（在错误波特率下的只听模式）  

 用符号解析文件显示接收 CAN 报文的信号，包括枚举（数值的列表）、

多工器、和 ID 范围 

 可以通过附的windows软件PCAN Symbol Editor创建Symbol文件，
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用于解析 CAN 报文 

 记录 CAN 报文到内存卡，可使用 CAN ID 过滤器  

 回放记录的 CAN 报文文件 

 通过 Windows®软件（PEAK-Converter）可把记录的文件转换成 ASC

或 CSV 格式 

 可以发送单个 CAN 报文或 CAN 报文列表  

 CAN 报文支持十进制、十六进制、或二进制输入。在运行时期间可改变

单个传送报文的数据  

 支持用符号文件传输 ID 和数据可读的 CAN 报文 

 测量 CAN 总线负载，用时间图显示，可切换显示错误帧 

 总线负载时间图可以保存为位图截屏 

 当系统正在运行，也可测量高速 CAN 总线的 CAN 终端 

 根据所使用的收发器模块，可切换所连接总线的 CAN 终端 

 测量 CAN 接头（D-Sub）上所有引脚的电压 

 在工程中管理设备配置、传送列表、符号文件以及所有记录的数据（截

屏、踪迹、和 CSV 文件）  

 总线关闭时可自动复位 

 

示波器功能 

 示波器含两个独立测量通道，每个通道最大采样率为 100MHz 

 显示 CAN_H 和 CAN_L 信号，也可以显示两个信号之间的电压差  

 触发可配置为  
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 帧开始和帧结束、  

 CAN 错误 

 CAN ID 

 CAN FD 帧的波特率切换  

 外部测量设备触发，使用 4mm 的 BNC 接头 

 显示原始 CAN 帧和 CAN FD 帧  

 从记录的信号踪迹中解码 CAN 帧和 CAN FD 帧  

 报告功能显示各种属性和解码 CAN 帧的测量数据  

 当前显示可截图保存为位图 

 存储器深度达 1M 

 记录的样本数据可存储为 CSV 文件  

 扩展的缩放功能  

 时间测量分辨率可达 10ns 

 

编辑软件 PCAN-Diag FD Editor for Windows 特性，随产品附带 

 方便配置所有可用设备的设置 

 编译传送列表 

 每个工程项目配置多个比特率 

 设备配置、传送列表，传送序列以及符号解析文件可保存在工程中  

 通过 USB 连接将工程传送到 PCAN-Diag FD 的存储卡 

1.2 发货清单 

 PCAN-Diag FD，附带充电器或不附带，防震塑料壳 
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 配置软件 PCAN-Diag FD Editor (for Windows） 

 Windows 操作系统下的 PCAN Symbol Editor 符号编辑软件 

 转换软件 PEAK-Converter （for Windows） 

 USB 连接线 

 电源单元为欧洲，美国和英国的可更换插头 

 HDMI/微型 HDMI 连接线 

 PDF 格式说明书 

 快速使用指引 

注释：充电器在 PCAN-Diag FD 的供电模块随带 
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2 开始使用设备 

有关 PCAN-Diag FD 的基本操作，请按顺序浏览本章的各个部分。 

 

2.1 CAN 连接（D-Sub） 

 

引脚分配 D-Sub，CAN 引脚符合规范 CiA®303-1，模拟输入引脚 6 可切

换到地（GND） 

模拟输入可用于-28 至+28V 范围内的一般电压测量。电压测量在第 5.3 节

中介绍。 

 

2.1.1 接地连接 

D-Sub 连接器的屏蔽和引脚 3 内部连接到电压接地（GND）。 

对于与其它 CAN 节点或测量对象的额外接地连接，在设备后部提供额外的

4 毫米 GND 插座。 
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出于测试目的，引脚 6 也可以切换到接地（Settings > Device Settings > 

Pin 6 GND connection）。 

 

2.2 电源供应 

PCAN-Diag FD 可以通过三种方式供电： 

 使用 AC 适配器通过设备背面的电源插座供电 

 设备位于充电站（AC 适配器连接到充电站） 

 暂时使用集成在设备内部的电池 
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操作时，供电状态显示在屏幕的上方状态栏上。 

图标 含义 

 连接外部电源（AC 适配器）。 

电量闪烁：集成电池正在充电。 

 内部集成电池供电。 

指示电池电量（此处约 60％）。 

 

电池大约充电时间: 

 充电站:约 2 小时 

 电源插座(无操作):约 4h 

 电源插座(运行时):约 11 小时 
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注意：无法通过 USB 连接供应 PCAN-Diag FD 或集成电池充电。 

 

2.3 使用旋钮和热键进行操作 

PCAN-Diag FD 通过按钮和四个热键进行操作。 

 

 

 

 

热键的功能各不相同，具体的功能会显示在显示屏上控制面板旁边的四个

区域中。 

 
 

2.3.1 开启设备 

按住按钮半秒钟以上。先显示开机屏幕，然后会显示主菜单。 

拨号盘： 
通过旋转改变和选择值 

按下： 
开启设备或执行所选功能 
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提示：如果无法打开确认有供电（外部电池或电池）的设备，请检查开机

锁定（设备背面的锁定开关）。 

要关闭设备，请从主菜单中选择 Power Off。或者，您可以选择 Power 

Off with Lock Switch，以便之后直接激活开机锁定。 

 

2.3.2 防止意外开机 

可以通过后部的锁定开关来阻止设备开机，以防止电池电量意外消耗。例

如，在运输过程中 

 

执行以下操作以激活开机锁定： 

如果设备已开启： 

在主菜单中，选择 Power Off with Lock Switch，然后将设备背面的锁定

开关推到锁定位置。 

如果设备关闭： 

将设备背面的锁定开关推到锁定位置。 

现在无法使用推拨盘启动设备。 

 



 

17 
 

2.4 设置日期和时间 

PCAN-Diag FD 具有内部集成时钟。将文件保存到内部存储卡时会使用时

间戳。我们建议您在首次启动设备后检查当前日期和时间（显示在屏幕的右上

角），并根据需要进行调整。 

执行以下操作以设置日期和时间： 

1.在主菜单中，选择 Settings。 

2.在 Device settings 部分，选择 Date & time 单击 Set。 

3.在 Date 和 Time 选取要调整的数字，然后通过拨号更改它的值。 

4.调整完所有数字后，按热键 1Set。 

 

2.5 状态指示 

操作设备时，屏幕右上方显示电源和 CAN 总线通信状态。 

图标 含义 

 连接外部电源（AC 适配器）。 

电量闪烁：集成电池正在充电。 

 内部集成电池供电。 

指示电池电量（此处约 60％）。 

 电池电压超出有效范围。 

打开设备后，由于内部电源的信息不能立即获

取，图标可能会出现一段时间。如果图标永久出

现，请联系我们的技术支持 
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T R CAN 数据：T =发送，R =接收 

闪烁：传出/传入 CAN 报文 

绿色：正常通信 

黄色，红色：通信故障 

act 

pas 

off 

表示总线状态（主动，被动，总线关闭）。当进入

总线关闭状态时，由于高（发送）错误率，不再

发送或接收 CAN 报文。在这种情况下，在修复

总线问题（例如，错误的 CAN 比特率）之后，

应该执行 CAN 控制器的复位。 

- CAN Data > CAN Message View > Reset 

- CAN Data > Receive Msgs. as Symbols > 

Rst 

- CAN Data > Transmit Messages > Reset 

- Settings > CAN Settings | Auto-reset on 

BusOff > x (autom.) 

L 设备以监听模式运行。如果静默启动功能检测到

设备的比特率和总线之间的差异（Setting），则

会自动激活它。也可以手动启用或禁用监听模式

（请参阅第 3.1.9 节）。 
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3 基础设置 

主菜单 Setting 

这里用于 CAN 总线连接的设置和设备使用的设置。 

使用“Save&OK”可以永久保存这些设置的更改。如果希望只是临时做更

改，直到关闭设备，请单击“OK”进行确认。后续会话（在关闭设备再重新开启

之后）再次使用初始设置。 

提示：您可以通过项目快速将设备设置调整到不同的应用场合（请参阅第

7 章）。 

 

3.1 CAN 

这部分菜单包含 CAN 和 CAN FD 连接的通信设置。 

 

3.1.1 静默启动 

如果激活这个功能，则在每次设备启动时，将检查设置的 CAN 比特率，通

过与所连接 CAN 总线上的数据流量。在这个过程中，设备使用只监听模式，以

避免 PCAN-Diag FD 对 CAN 总线通讯产生影响。顶部的 L 用于指示这个动

作。 

如果设备的比特率匹配，则在短时间后设备停止只监听模式；否则它将保

持监听的状态。 

提示：您可以使用相应的设备设置手动激活或取消激活只监听模式。 
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3.1.2 测试 CAN 比特率 

如果连接到 PCAN-Diag FD 的 CAN 总线的比特率未知，则 PCAN-Diag 

FD 可以自动检测到它。这需要至少两个节点之间的 CAN 总线数据通讯。 

比特率检测方法如下: 

1、点击 Detect 

2、选择正在连接的 CAN 总线上使用的协议（CAN protocol)。 

3、确保连接的 CAN 总线上 CAN 节点之间有 CAN 通信 

4、按下 Start 热键开始检测过程。根据设置的 CAN 协议，尝试多个比特率

  或比特率集。此过程需要一定时间。 

5、如果已检测到比特率或比特率设置，请单击确认按下 APPLY 热键。修

改        CAN protocol，Allow bit rate switch 和 Bit rate 并设置检测到

的比特率或比特 率设置。 

6、用 OK 或 SAVE&OK 热键(后者用于永久保存)确认设置。 

3.1.3 CAN 协议 

有三种协议被支持：CAN2.0B，FD iso 和 FD non-iso。 

注意：自从首次实施 CAN FD 以来，该标准得到了改进，最终在规范 ISO 

11898-1 中发布。修订后的 CAN FD 标准与原始协议不兼容。PEAK-System 在

CAN FD 接口中同时支持两种协议版本。根据需要，用户可以通过软件切换使

用的 CAN FD 协议。 
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3.1.4 允许比特率切换 

允许 CAN FD 帧的比特率切换，以便除了标称比特率之外，还可使用 CAN 

FD 帧的数据部分的单独比特率。 

注意：此设置必须与 CAN 总线上所有其他 CAN FD 节点的设置相对应。 

 

3.1.5 比特率 

通过 Edit，可以选择预设或用户定义的 CAN 比特率，对应于连接的 CAN

总线上的比特率。选择选项取决于在高级设置屏幕中选择的 CAN 协议: 

 CAN 2.0： 

根据在时钟部分中选择的频率，可以得到不同的比特率列表。 

 CAN FD( ISO 标准 和 非 ISO 标准): 

时钟频率集，标称比特率和数据比特率可供选择，作为所谓的比特率集。 

注意：在为 CAN FD 选择比特率设置时，也要注意附加设置(Allow bit rate 

switch)有需要的话，允许使用数据比特率。 

 

如果列表中没有合适的比特率或比特率集，可以使用“New BR”热键创建新的比

特率或比特率集。 

执行以下操作可以创建一个新的比特率或比特率集: 

1、按下 New BR 热键 

2、使用 Type 确定是要创建一个比特率集(标称比特率和数据比特率)还是单个

比特率。创建的标称和数据比特率在设备中是可用。 
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3、选择 Clock 频率作为计算比特率的基础。 

4、用四个参数设置比特率: 

 BRP 预分度器，产生时间量子 Tq 

RTSEG1/2:段长度(时间量程计数) 

SJW:同步跳转(时间量子计数) 

提示：PEAK-System 为 Android、iOS 和 Windows 提供了“比特率计算工

具”，以帮助您指定正确的参数。您可以咨询虹科索要。 

5、最后，按下 ADD 热键。 

 

3.1.6  CAN 终端电阻 

高速 CAN 总线需要使用 120Ω的电阻在两端进行电气连接。如果 PCAN-

Diag FD 连接到 CAN 总线的未端，则可以在此处使用 124Ω的内部终端电阻。 

 

3.1.7 监听模式 

如果您希望设备不影响 CAN 总线上的通讯，即将其用作纯监控工具，则必

须激活监听模式（On）。这样，设备既不会 ACK 确认也不会传输 CAN（错

误）帧。此外，活动发送列表会被停用。 
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3.1.8 BusOff 上的自动复位 

如果该功能被激活（On），PCAN-Diag FD 会在由于许多传输错误而变为

BusOff 状态时自动执行 CAN 控制器的复位。这可以用于：在其它 CAN 节点

上使用比特率进行实验。 

 

3.2 显示 

这部分菜单包含屏幕和显示设置。 

 

3.2.1 简介 

确定设备打开时是否显示启动画面。 

 

3.2.2 显示方向 

屏幕方向可以自动确定或设置为以下值：0°（纵向视图），90°（横向视

图，控件在右侧），180°（纵向视图，上下颠倒），270°（横向视图，控件在左

侧）。 

 

3.2.3 HDMI 输出 

一旦连接到外部屏幕（DVI 信号，1024 x 768 像素，4：3），屏幕信号就

会路由到 Micro-HDMI 输出。同时，关闭 PCAN-Diag FD 的屏幕。 

这个选项可以被禁用，例如暂时中断视频传输而不需要移除 HDMI 电缆。 
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注意:如果 DVI 连接在选项开启时中断或恢复，只有在主菜单激活时才会在

外部屏幕和设备屏幕之间进行切换。 

3.2.4 屏幕保护程序超时 

只要设备未运行一段时间，显示屏的亮度就会降低。这可以延长电池的使

用时间。 

 

3.2.5 背光强度 

屏幕亮度可以设置为 30％到 100％的范围内的值。默认值为 70％。 

 

3.3 设备 

这部分菜单包含设备的设置。 

 

3.3.1 D-Sub GND 连接 

D-Sub 连接器的引脚 6 可以在内部连接到器件接地（引脚 3，屏蔽，

GND）以进行测试（On）。 

注意：如果 CAN 电缆的引脚 6 用于接地连接之外的其他用途，则必须禁

用此设置（Off），以避免电源与地之间发生短路。 
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3.3.2 蜂鸣器 

PCAN-Diag FD 可以为多个事件提供声音反馈。其中，CAN 总线状态的变

化是基于信号的。设置 Off 禁用 PCAN-Diag FD 的声音功能。 

 

3.3.3 关机时间（电池） 

如果 PCAN-Diag FD 使用电池运行，只要没有使用推拨盘，就可以在设定

的一段时间后自动关闭设备来保存电池电量。设置为 Never 会导致设备始终保

持活动状态。 

如果使用外部电源操作设备，例如使用随附的 AC 适配器，则此设置不会

生效。 

注意：该模式下，只要有报文被记录，设备就会保持开机状态。这可能会

导致在报文记录停止之前电池就已耗尽。对于较长的报文记录，我们建议使用

外部电源进行供电。 

3.3.4 日期和时间 

通过 Set 可以对设备的日期和时间进行调整。当保存文件到内部存储卡时

会使用日期和时间。 

 

3.3.5 重置文件索引 

要保存的位图或范围数据的文件名获得来自计数器的数字。 当前计数显示

在括号中，可以通过单击 Reset 将其设置为 0。 
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3.3.6 USB 类型（重启请求） 

PCAN-Diag FD 可以作为 USB 从设备或 USB 主机运行。重启设备后，更

改的设置处于活动状态。 

注意：主机功能暂时不可用。 

 

3.3.7 USB 自动连接 

这里可以设置与 PC 上操作系统的 USB 连接是自动（On）的或手动

（Off）的。有关更多信息，请参见第 10 章。 
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4 CAN 通讯 

主菜单项：CAN Data 

PCAN-Diag FD 可以以十六进制格式（4.1 节）的简单方式显示接收到的

CAN 报文/CAN 数据，或者借助信号解析文件将数据转换为更易读的形式（第

4.2/4.3 节）。 

另一方面，可以定期或手动发送准备好的 CAN 报文（第 4.4 节）。 

此外，还可以将传入的 CAN 数据记录到内部存储卡上的文件里。录制的数

据可以稍后以 1：1 进行回放，或者在 PC 上可以转换为各种输出格式

（4.5/4.6/4.7 节）。 

 

4.1 显示收到的 CAN 报文 

菜单项 CAN Data > Raw CAN Messages  

屏幕上最多可以看到三个垂直排列的区域: 

 总是显示传入 CAN 消息的列表(RxID 列) 

 可以显示或隐藏的传输列表(TxID 列) 

 可以显示或隐藏的传输序列（Tx Sequence Name 列） 

按以下方法显示或隐藏传输区域: 

1、通过使用推拨盘，将选择框移动到菜单栏上，并单击激活。 

2、单击 View，直到看到想要的视图。视图顺序:无发送区域>发送列表>

   发送列表+发送序列>发送序列>无发送区域 

提示:在“Settings”菜单项中，视图可以被永久保存。 
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Reset  

清除收到的 CAN 报文列表并重置 CAN 控制器。在 CAN 总线进行故障维

护后，重置功能非常有用。 

只要一个区域没有被选中(区域上的浅黄色框架)，也可以通过热键执行重

置。 

View 

通过单击打开或关闭屏幕上的其它区域，以便发送 CAN 报文： 

 发送列表 

 发送列表和发送序列 

 发送序列 

可以在“Setting”下永久设置视图（请参阅以下说明）。 

有关发送区域的进一步说明，请参见第 4.4 节。 

Settings 

可以在此处配置发送区域的视图，并在需要时永久保存。 

Transmit View 

如前所述的发送区域的视图。 

Current Tx List 

目前使用的传输列表（*.xmt）。通过选择，可以从内部存储卡加载另一个

发送列表。 

Save Tx List on Exit 

保存发送列表中的新更改，从不 Never，每次询问 Ask，总是 Always。 
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更改设置后，使用“Save&OK”（热键 2）永久保存设置。如果只想临时

（在当前会话期间）使用更改的设置，请单击“OK”（热键 1）。后续会话（在重

启设备之后）再次使用初始设置。 

4.1.1 输入的 CAN 报文 

收到的 CAN 报文通过列表显示，按收到的 CAN ID（列 RxID）排序。

CAN 数据字节（Data D ... N）的表示采用十六进制格式。每次出现 CAN 报文

都会增加其计数器（Count）。计数从调用 CAN 报文视图开始。列 T.Diff.表示

CAN 报文最后两次出现之间的时间差（仅在纵向视图中显示）。 

红色列表条目表示 CAN 控制器报告的 CAN 错误。 

 

执行以下操作以更改接收列表中的排序和视图： 

1. 通过转动，将选择帧放置到接收列表中。 

2. 要移动单个消息或更改其表示，请按下拨号盘并将选择框移动到接收列

表中所需的 CAN 报文上。 

3.按热键 3Menu 并选择所需的操作，具体取决于整个接收列表或单个报

文的选择。 

4.1.2 发送列表 

发送列表包含带有静态数据的独立 CAN 报文。报文可以循环或手动传输。 

 

如果列表不可见，执行以下操作来显示传输列表区域(TxID 列): 

1、使用推拨盘，将选择框移动到菜单栏上，并单击激活 
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2、单击 View，直到看到想要的视图。视图顺序:无发送区域>发送列表> 

  发送列表+发送序列>发送序列>无发送区域。 

 

传输方法： 

 手动选择 CAN 报文并按下 SEND 热键或点击讯息(仅当周期时间为 0 时)。 

 周期性，给定一个大于 0 的循环时间，则为循环传输。通过点击相应的 CAN

报文，可以开启或关闭循环传输;按下 MENU 热键，然后单击“Start ALL 或

者 Stop All 

 

填充发送列表： 

传输列表可以从文件(*.xmt)填充或手动填充。 

提示：您可以使用免费的 Windows 程序 PCAN-View 创建一个传输列表文

件。 

 

 要从内部存储卡打开一个传输列表文件，请执行以下步骤: 

1、确保传输列表（RxID 列）能够显示出来(菜单项 View) 

2、通过转动，将选择帧放置到传输列表上。 

3、按下 MENU 热键，然后点击 Load File。显示当前项目目录下的所有传

输列表文件(*.xmt) 

4、单击所需的传输列表文件。传输列表中填充了来自该文件的所有 CAN 报

文。先前的记录会被删除。 
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 要将 CAN 报文添加到发送列表，请执行以下操作: 

1. 通过转动，将选择帧移动到传输列表（上方区域）并单击。 

2. 按下 MENU 热键，然后点击 Load File 

3. 在发送列表中输入新的 CAN 报文的参数。 

4. 按 OK 热键。新的 CAN 报文就会出现在发送列表中。 

 

注意：发送列表的更改：Settings  > Save Tx List on Exit 

4.1.3 传输序列 

传输序列包含多个 CAN 报文，这些报文按照设定的间隔连续传输。 

执行以下操作可显示传输序列区域( Tx Sequence Name 列): 

1、通过使用推拨盘，将选择框移动到菜单栏上，并单击激活。 

2、单击 View，直到看到想要的视图。视图顺序:无发送区域>发送列表> 发

送列表+发送序列>发送序列>无发送区域 

 

传输方法： 

 手动选择发送序列并按下 SEND 1X 热键。 

 循环；通过点击传输序列来开启或关闭。 

 

创建传输序列 

在 Windows 软件程序 PCAN-View 的帮助下创建一个传输序列，然后使用

PCAN-Diag FD 编辑器接入到一个项目中。它将一个传输列表（*.xmt）文件

扩展名更改为*.xms 后作为传输序列。 
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执行以下操作创建传输序列: 

1、启动 Windows 程序 PCAN-View，例如从内部存储卡的 PCAN-Diag FD 启

动(directory \PCAN-Diag FD \ Tools \PCAN-View \)。 

2、在 Transmit 窗口中创建 CAN 报文列表。稍后的 CAN 报文的循环时间决定

了之后消息的延迟。 

3、保存传输列表(*.xmt)并将文件扩展名重命名为*.xms。 

4、在 PCAN-Diag FD 编辑器的 CAN Sequence Lists 页面中，导入先前创建的

传输序列文件。 

5、将带有传输序列的项目转移到 PCAN-Diag FD 并打开。(如果正在使用另一

个项目)。 

 

4.2 以信号形式表示 CAN 数据 

菜单项 CAN Data > Receive Msgs. as Symbols 

为了让 CAN 数据更加易读，报文可以用通过信号形式被解读。解读方式由

信号文件决定。 

注意：在以信号形式表示 CAN 数据之前，必须在项目中加载信号文件。有

关详细信息，请参阅第 4.3 节管理信号文件。 

4.2.1 信号表示性质 

 用一个信号来标识一个 CAN ID。 

 CAN 报文中表示单个数量的位序列由变量或信号指定名称。 
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 数据可以用十进制、十六进制或二进制格式表示。PCAN-Diag FD 中的二进

制表示最多使用 16 位。如果需要更多的二进制数字，该值将自动以小数而

不是二进制表示。 

 变量可以对 CAN 传输的原始数据进行转换，用单位表示为物理量。 

 特定的变量值可以通过使用枚举(值列表)以字母数字表示。 

 多路复用器为单个 CAN ID 的数据输出定义了不同的信号定义。 

4.2.2 输入 CAN 报文 

 菜单项 CAN Data > Receive Symbols 

 

传入的 CAN 报文(信号)显示在列表视图中。包含在 CAN 报文中的值(变量/信

号)出现在子列表中。 

注意：目前，没有数据长度规范的接收信号定义(“Valid for all data lengths”)

不被 PCAN-Diag FD 支持。CAN 报文在列表中将以红色突出显示。 

 

此外，传输序列在屏幕的下部可用，它们不使用符号表示。在两个区域之间切

换是通过 GoTo Tx  / GoTo Rx 热键完成的。更多关于传输序列及其处理的信

息，见第 4.1.3 节。 

当前激活的信号文件在下方的状态栏中用 Name 表示。可以使用菜单命令

CAN Data  > Manage symbol Files 来选择不同的信号文件。 

 

自定义列表显示 
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显示自定义 用户操作 备注 

展开或折叠一个符号 使用拨号盘点击符号或

它的数据 

展开或折叠所选符号的

数据。 

展开或折叠所有符号 按下拨盘（1.5 秒）。 展开或折叠所有符号的

数据 

完全隐藏一个符号 点击 CAN Data > 

Manage Symbol Files 

符号可以永久地在那里

隐藏。 

对显示的符号进行排序 按 SORT 热键，并选择

元素进行排序。 

列表中对排序顺序有影

响的更改不会被动态处

理。要重新排序列表，

请再次选择 SORT 命

令。 

补充列表 按 RESET 热键。 此外，对 PCAN-Diag 

FD 的 CAN 控制器进行

了复位。此行为在 CAN

总线上进行故障维护之

后有较大意义的。 

 

4.2.3 输出 CAN 报文 

 主菜单 CAN Data > Transmit Symbols 
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发出的 CAN 报文(符号)显示在列表视图中。包含在 CAN 报文中的值(变量/信

号)显示在子列表中。 

 

根据激活的信号文件，为了传输而创建的每个符号定义都有一个条目。当前激

活的符号文件在下方的状态栏中以 Name 表示，可以通过菜单命令 CAN 

Data > Mange Symbol Files 选择不同信号文件。 

 

传输方法： 

 手动点击一个符号 (例外:周期时间的符号)。 

 如果符号定义包含循环时间，则为循环传输。单击此消息将中断循环传输过

程，再单击一次，继续传输过程。该条目将在列表中显示为红色。 

 

修改数值： 

使用 EDIT 热键，可以修改信号的循环时间，也可以修改变量/信号的相应值。 

 

此时会出现一个编辑窗口。拨盘可以用来修改数值中的单个数字，DEL 热键可

以用来删除一个数字。 

 

当传送符号屏幕上出现 EXIT  时，会出现一个提示，询问是否保存更改的值。

然后在设备重新启动后可以再次使用。 

 

提示：当您创建一个信号文件时，请为各个变量/符号指定默认值。 
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自定义列表显示： 

显示自定义 用户操作 备注 

展开或折叠一个符号 使用拨号盘，点击一个符

号并保持(1 秒)。 

展开或折叠所选符号的

数据。 

展开或折叠所有符号 按下拨盘（1.5 秒）。 展开或折叠所有符号的

数据。 

完全隐藏一个符号 使用 PCAN-Symbol 

Editor 显示模式“Off”到

符号定义。 

符号可以通过要与项目

一起导入的符号文件永

久地从显示中隐藏。 

补充列表 按 RESET 热键。 对 PCAN-Diag FD 的

CAN 控制器进行复位。

在 CAN 总线上进行故障

维护后，此行为是有用

的。 

 

4.3 管理信号文件 

菜单项 CAN Data > Manage Symbol Files 

信号文件用于定义 CAN 报文的信号如何表示。 

使用信号文件： 

 一个项目在 PCAN-Diag FD 中可以包含一个或多个信号文件（更多关于
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第 7 章中的项目）。 

 在 PCAN-Diag FD 中显示信号，只能使用一个信号文件。 

 信号文件可以通过不同方式创建和更改（在 PC 上）： 

 使用提供的 Windows 程序 PCAN Symbol Editor（请参阅第 4.3.1

节） 

 在文本编辑器中 

 通过导入 CANdb 数据库（仅适用于带有 CANdb 插件的许可

Windows 程序 PCAN-Explorer 6，两者均可从 PEAK-System 获

得） 

 PC 上的任何信号文件（*.sym）都可用于项目。使用 Windows 程序

PCAN-Diag FD Editor 创建项目（请参见第 7.1 节）。 

 在 PCAN-Diag FD 中使用的信号文件中可包含的元素最大数量如下： 

 450 个接收的 symbol 

 每个 symbol 可以设置 40 个 variable 

 最多 1100 个 variable 

 400 个 enum 

在 PCAN-Diag FD 中，选择要使用的信号文件，并确定显示该信号文件中

的哪些元素。 

Select File 

显示当前项目提供的信号文件列表。选择一个用于表示在 Receive Msgs. 

as Symbols。 

Edit File 



  

   38 
 

显示当前信号文件的预览。选择要以信号形式表示 CAN 报文时要显示的元

素。单击条目可以更改其状态。使用 Sel.All 重新激活所有显示条目，使用

Sel.None 关闭激活所有显示条目。 

 

4.3.1 使用 PCAN Symbol Editor 创建信号文件 

借助示例，本节介绍如何使用提供的 Windows 程序 PCAN Symbol 

Editor 6 创建信号文件。该示例以以下 CAN 报文为例： 

 

执行以下操作以创建信号文件： 

1.启动 Windows 程序 PCAN Symbol Editor（PcanSEdt.exe）。例如，您

可以在提供的 DVD 上的目录中找到该程序：/Tools/PCAN-Diag FD/Tools/ 

2.程序启动后，通过单击所需的文件格式创建一个新的信号文件。文件格

式 6.0 支持 CAN FD 标准。 
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3.之后，左侧项目导航器中的文件夹是空的。打开 Edit 功能区，然后选择

Add Symbol。 

 
项目导航器的 Symbols 文件夹中将出现一个新条目。 

4.根据 TestSymA 帧的给定值调整属性面板中的项目。 
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对标记的项目进行调整。 

5.单击 Add Variable。与之前的帧一样，根据 Speed 变量的给定值调整

项目。 

 

6.对 Temperature 变量重复上一步进行设置。 
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要显示负数值，必须将数据类型设置为有符号数。 

7.使用 Add Enum 创建开关枚举，稍后用于 Switch1 信号。项目导航器的

Enums 文件夹中将显示一个新条目。 

8.使用 Add Value 将两个状态 Off（0）和 On（1）添加到枚举常量。 

9.使用 Switch1 信号创建 TestSymB 帧。 
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该信号使用 Switches 枚举。 

10.使用另存为以 SymExample.sym 为名保存信号文件。 

最终的文件具有以下内容： 
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4.3.2 在信号文件中使用多路复用器 

多路复用器用于不同的信号定义表示来自同个报文帧的 CAN 数据。CAN

数据的一个区域被定义为多路复用器。包含的值决定 CAN 报文中其余数据的信

号表示。借助示例，本节介绍如何创建使用多路复用器的信号文件。 

 

执行以下操作以创建信号文件： 

1.启动 Windows 程序 PCAN Symbol Editor（PcanSEdt.exe）。例如，您

可以在提供的 DVD 上的目录中找到该程序：/Tools/PCAN-Diag FD/Tools/ 
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2.程序启动后，通过单击所需的文件格式创建一个新的信号文件。文件格

式 6.0 支持 CAN FD 标准。 

 

3.打开 Edit 功能区并选择 Add Symbol。 
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4.根据 MuxSym 帧的给定值调整属性面板中的项目。 

 

这里数据长度是无关项，稍后需要针对每个多路复用器单独确定。 
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5.使用 Add Multiplexer 将两个多路复用器添加到帧。 

 

Multiplexer2 使用值 01h（Multiplexer Value）。 

当在 PCAN-Diag FD 中使用信号文件时，多路复用器被视为名称为 Mux

的单个信号。PCAN Symbol Editor 中给出的名称将被取消。因此，对于两个

多路复用器，只要给出它们的值，多路复用器就会生效。 

注意：如果帧包含具有动态数据长度的多路复用器（设置“Valid for all 

Data Lengths”），则只有该单个多路复用器用于 PCAN-Diag FD。忽略相应帧

中的其余多路复用器。数据长度来自包含的信号。 

 

5.使用 Add Variable 将 Speed 信号添加到 Multiplexer1，并根据示例调

整条目。 
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7.使用 Add Variable 将 Engine 信号添加到 Multiplexer2，并根据示例调

整条目。 

 

8.使用信号格式 6.0，可以定义全局的信号，这些信号是为整个文件定义

的，然后可以重复使用。对于此示例，创建温度信号并将其添加到两个多路复

用器。 

使用 Add Signal 添加新的温度信号，并根据示例调整条目。 
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9.通过选择项目导航器中的每个多路复用器，然后选择分配信号（添加信

号的子项），将信号分配给两个多路复用器。 

10.使用另存为以名称 MuxSymExample.sym 保存符号文件。 

下图显示了 PCAN-Diag FD 屏幕上多路复用器的两种显示可能性： 

在通用视图中，所有多路复用器的信号显示在单个列表中。如果给定名称

和变量的所有参数对于所有多路复用器都相同，则此信号仅列出一次。 

在单独的视图中，每个多路复用器定义显示为单独的组（从 PCAN-

Explorer 中已知）。 

在信号选项卡上添加信号文件时，在 Windows 程序 PCAN-Diag FD 

Editor 中确定视图。 
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4.3.3 减少信号文件的大小 

由于 PCAN-Diag FD 中的工作内存有限，信号文件只能读取到特定大小

（另请参见第 4.3 节的开头）。减小信号文件大小的一种可能性是使用 Display 

Mode 属性。 

您可以在帧，多路复用器和信号的属性中找到 Display Mode。 

 

 

信号定义中的 Display Mode 属性 

此属性的默认值为 On。如果为 Off，则 PCAN-Diag FD Editor 不会再处

理该元素。将项目传输到 PCAN-Diag FD 时，Display Mode 关闭的元素不会

被编译到二进制符号文件（*.syb）中。 

使用此方法可以减少信号文件的大小，而无需删除帧，多路复用器或信

号。 
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4.4 记录 CAN 数据 

菜单项 CAN Data > Trace Messages 

使用此功能，输入的 CAN 数据将记录到 PCAN-Diag FD 的内部存储卡上

的记录文件中。还考虑了 CAN 报文的时间。 

稍后，可以使用记录文件在 CAN 总线上回放记录的 CAN 报文（参见第

4.5 节）。或者，可以在 PC 上分析或回放文件。 

 

标识 含义 

Drive 使用过的数据载体的名称。M0：指示灯代表内

部存储卡。 

Folder 数据载体上文件的路径。这些文件将保存到活

动项目目录下的 Traces 目录中。 

File 用于下一次录制的记录文件的名称

（YYYMMDD_0000.trc）。文件名从当前日期

和连续数字自动放在一起。 

 

4.5.1 记录设置 

Overwrite 

设置 描述 

[x] 如果给定的 File 已经存在，原文件将被覆盖。 
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[ ] 每次记录时，文件名中的连续编号都会递增，

之前的文件不会被覆盖。 

Max. Size 

指定记录的最大尺寸(值为 10 到 500 MByte)。 

File format 

设置 描述 

.btrc (binary) 

（推荐） 

使用二进制文件格式(*.btrc)完成

记录。为了在 PC 上进一步使

用，需要使用 Windows 软件

PEAK-Converter 进行转换(参见

章节 4.6) 

.trc (ASCII) 记录是在 PEAK-System 的文本

格式 2.0 中完成的，可以直接使

用，例如在 PCAN - Explorer 中

使用。 

注：此格式仅用于低总线负载(如

在 500kbit/s 下最大负载的

30%)，以避免在记录期间数据丢

失。 
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Multi file 

设置 描述 

[x] 如果达到记录文件的 Max.Size，将在新文件中继续

录制。新的文件名使用连续数字区分。 

[ ] 如果达到记录文件的 Max.Size，记录自动停止。 

Data 

如果启用，则会记录常规的 CAN 报文。 

Errors 

如果启用，则会记录 CAN 错误帧。 

Status 

如果启用，则会将内部状态消息添加到 CAN 报文的记录中。 

4.4.2 执行记录 

使用热键开始记录： 

1.确保 PCAN-Diag FD 和 PC 之间没有．．USB 连接。 

2.使用 START 开始记录。在此过程中，记录文件的大小以 kByte 表示。 

3.您可以 PAUSE 暂停或 STOP 停止记录。如果未启用 Multi file，它就会

在达到最大文件大小时自动结束。 

 

4.5 在 CAN 总线上回放 

菜单项 CAN Data > Play Back Trace 
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PCAN-Diag FD 可以将记录文件（*.trc 或*.btrc）中的 CAN 报文回放到

连接的 CAN 总线上。在文件记录期间原本发生的 CAN 报文的时间戳会被保

持。 

注意：在 PCAN-Diag FD 上，当运行文本格式(*.trc)的记录文件时，可能

会出现 CAN 报文的传输延迟。对于无延迟回放，记录文件的内容在 500kbit /s

时不应生成高于 30%的总线负载。对于记录和回放，建议使用二进制格式 

（*.btrc） 。 

 

执行以下操作以回放记录文件： 

1.单击 SelectFile，从项目目录中选择一个记录文件（*.trc 或*.btrc）。 

2.使用 Loop mode 设置记录文件回放的次数。选择 infinite 可连续回放。 

3.按热键 PLAY 开始播放。之后可进行以下操作： 

功能 执行 

PAUSE 暂停播放。PLAY 会在之前中断的位置继续播

放。 

STOP 结束回放。 

 

4.6 在 PC 上使用记录的 CAN 数据 

PC 上可以通过 USB 连接读取 PCAN-Diag FD 内部存储卡上记录的 CAN

数据。记录文件*.trc 或*.btrc 位于当前项目的 Traces 子目录中。 
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如果使用 Packed 设置，则录制将保存到二进制编码的记录文件*.btrc

中。要进一步使用，您必须以适当的格式转换数据。为此，在 DVD 和

PCANDiag FD 的内部存储卡上可以找到 Windows 程序 PEAK-Converter。 

 

可能的转化格式： 

目标格式 文件扩展名 解释/用途 

PCAN-

Trace 

.trc PEAK-System 基于文本的跟踪格式; 查

看 PCAN-Explorer 中的数据或使用

PCAN-Trace 程序播放 CAN 消息。 

提示：与 PCANDiag FD 的跟踪文件相

关，我们建议使用格式版本 2.0，因为

CAN FD 支持。 

Vector 

ASC 

Trace 

.asc Vector Informatik 公司基于文本的记录

格式，也可供某些第三方程序使用。 

字符分隔

值 

.csv 基于文本的格式，常用于导入电子表格

（分号作为分隔符）。 

 

要进一步使用二进制编码的记录数据，请按以下步骤操作： 

1.使用 USB 电缆将 PCAN-Diag FD 连接到 PC（另请参见第 10 章）。 

2.在 Windows 下，从 PCAN-Diag FD 的内部存储卡的根目录/PCAN-

Diag FD/Tools 启动 PEAK-Converter.exe 程序。 
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3.源文件选择二进制编码的跟踪文件（*.btrc）。记录文件位于项目目录

中：/PCAN-Diag FD/Projects/<项目名称>/Traces 

4.指定目标文件并选择所需的目标格式（参见上文）。 
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5 CAN 总线的测量功能 

主菜单项 Measurements 

本章介绍 PCANDiag FD 的测量功能。示波器功能将在第 6 章中介绍。 

 

5.1 负载率 

菜单项 Measurements > Bus Load 

提示：您可以通过项目快速将总线负载设置调整到不同的应用场合（请参

阅第 7 章）。 

只要 CAN 总线上没有传输消息，它就处于空闲状态。总线负载是空闲状态

和 CAN 帧的持续时间的比率。0％对应于根本没有 CAN 帧。100％对应于连续

不断的 CAN 帧传输，中间没有任何空闲状态。具有 CAN 报文的 CAN 总线的

利用率百分比会在一段时间内以图形显示并且不断更新。 

图表的采样间隔持续时间来自 CAN 比特率和设置的 Samples per bar。

每个采样值会计算总线负载的平均值和最大值，并在 Current avg. bus load

显示为条形图和百分值。 

您可以通过以下措施抵消高总线负载： 

 提高总线上所有 CAN 节点的比特率。 

 增加 CAN 网络中特定帧的周期时间，以减少它们的出现（减少 CAN 帧

数量）。 
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5.1.1 总线负载图 

使用 SAVE BMP 热键，总线负载率屏幕的位图保存在内部存储卡上（文件

名：pict000.bmp 连续编号）。 

在存储卡上，文件将写入激活项目的目录（Projects> <project 

name>）。从主菜单的下方状态栏中获取激活项目的名称。 

通过 USB 连接在 PC 实现对保存文件的访问。请参见第 10 章。 

5.1.2 总线负载测量设置 

通过 SETTINGS 热键，显示那些设置的屏幕，参考总线负载测量的显示。 

Show busload         

Show max.busload     

Show errors           

前两个选项决定在总线负载图中显示哪些值: 

 平均值（黄色条） 

 最大值（红色条） 

总线负载图始终显示(至少有一个选项是活跃的)。在另一个图表中，错误

率可以用蓝色条显示。 

 

Y-scale max.busload（%）  

总线负载图所能表示的最大百分比。所有超过数值的条将在顶部被截断。 

默认值:10 

Y-scale max.error rate（%） 
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错误率图所能表示的每秒最大错误数。所有超过数值的条将在顶部被截

断。 

默认值:10 

Samples per bar           

确定用于计算条形图的一个条形的测量值（样本）的数量。 

 

5.2 CAN 总线终端电阻 

菜单项 Measurements > CAN Termination 

该功能测量 CAN_L 和 CAN_H 线之间的电阻值。测量时 CAN 通讯不受影

响。 

高速 CAN 总线（ISO 11898-2）必须在 CAN_L 和 CAN_H 之间的两端以

120Ω端接。此措施可防止电缆末端的信号反射，并确保连接到 CAN 总线的

CAN 收发器能正常通信。 

并联的两个终端电阻使总电阻为 60Ω。总电阻的测量提供了有关正确 CAN

总线终端的信息。 

注意：PCAN-Diag FD 的可切换内部终端电阻会包含在 CAN 总线的终端

电阻测量中。 

 

执行测量 

在 Start measurement 条目中，单击 Start 



 

59 
 

电阻测量大约每秒钟更新(Satus: Running)，直到你点击 Stop (Satus: 

Stopped)。最后一次测量的结果显示在 Result 行中，也以图形方式显示在条

形图中。 

 

测量值 解释 

~ 60 Ohm 在测量方面，CAN 总线的终端阻值是没问题的。 

确保终端电阻位于总线的两端，而不是位于总线中间的

分接头处。 

~ 120 Ohm 仅存在一个终端电阻。 

在另一侧的总线端安装另一个 120 欧姆的电阻。 

< 45 Ohm CAN 总线上存在太多终端电阻。 

原因可能是在一个总线端安装了单独的终端电阻以及带

有内部终端电阻的 CAN 节点。 

--- Ohm 测量未成功。 

Termination 

missing 

CAN 总线缺少终端电阻，或者使用过的电阻太大。如上

所述设置正确的终端电阻。 

Shorted 短路( <10 ohm)，检查 PCAN - Diag 连接是否正常。 

跳值 检查 PCAN - Diag 连接是否正常。例如，CAN 线 CAN- 

High 和 CAN- Low 可以尝试在 CAN 总线上交换。 

 

Int. CAN termination 

如果为开启，则激活内部终端电阻（124Ω）。 
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更改此位置的设置仅暂时保存（直到设备关闭前）。可以在常规设置（主菜

单项设置）中永久设置内部终端电阻。 

Calibration 

终端电阻的测量装置必须进行校准，以避免测量值与实际电阻值有较大偏

差。已完成的校准以其日期表示。 

如果 No calib 无显示则测量值无效，可通过菜单入口进行电阻测量的校

准，Support > Calibration CAN Termination(详见 8.7)。 

 

5.3 测量在 D-Sub 连接器上的电压 

菜单项 Measurements > Analog 

测量 D-Sub 连接器的引脚 6 和 9 的电压电平，并在图中显示。 

Settings 

自定义每个引脚的视图。 

Show Pin 6 Voltage 

显示 D-Sub 连接器引脚 6 上的电压。 

Show Pin 9 Voltage 

显示 D-Sub 连接器引脚 9 上的电压。 

Bar Width 

确定图表中显示的条形宽度。 

Bar Height 

确定图表中显示的条形的高度。 

Bar Separation 
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确定图表中两个条形之间的间隙。 

Min. Voltage [V] 

确定要在图表中显示的电压的最小值。 

Max. Voltage [V] 

确定要在图表中显示的电压的最大值。 

Offset Pin 6 [digit] 

确定引脚 6 的电压显示偏移量，以数字表示。 

Offest Pin 9 [digit] 

确定引脚 9 的电压显示偏移量，以数字表示。 

Save as BMP 

总线负载率屏幕的位图保存在内部存储卡上（文件名：pict000.bmp 连续

编号）。 

在存储卡上，文件将写入激活项目的目录（Projects> <project 

name>）。从主菜单的下方状态栏中获取激活项目的名称。 

通过 USB 连接在 PC 实现对保存文件的访问。请参见第 10 章。 
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6 示波器功能 

主菜单项 Scope 

PCAN-Diag FD 的示波器功能用于对连接线路 CAN_High 和 CAN_Low 上

的 CAN 数字信号进行深入诊断。它独立于 PCAN-Diag FD 中的 CAN 通信。因

此，它为 CAN 总线上的故障排除提供了另一个实例。除了信号过程的纯显示和

光标的测量可能性之外，示波器功能还显示统计信息。处理类似于标准存储范

围。 

 

6.1 示波器功能的属性 

 两个独立的测量通道，每个通道的最大采样率为 100 MHz 

 显示 CAN 高和 CAN 低信号以及两个信号的差分信号 

 通过不同的 CAN 帧属性配置触发： 

 帧的开始和结束 

 CAN 错误 

 CAN ID 

 CAN FD 帧的比特率切换 

 可使用 4 mm 香蕉插座触发外部测量设备 

 原始 CAN 和 CAN FD 帧的描述 

 从记录的信号过程中解码 CAN 和 CAN FD 帧 

 使用报告功能显示各种属性和解码 CAN 帧的测量数据 

 保存当前视图的截图为位图 
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 存储深度最高可设置为 1 M 个采样点数据 

 将样本数据保存为 CSV 文件 

 时间测量，分辨率高达 10 ns 

 

6.2 示波器屏幕的元素 

 

A：采样缓冲区的缩略图，同时指示位置（当前视图，触发器，测量光

标） 

B：来自 CAN 收发器的接收（Rx）和传输（Tx）的 CAN 信号，包括位周

期（蓝色） 

C：可进行的操作（参见手册后面的部分） 

D：将信号源解码出的 CAN 数据 

E：将信号源解码出的 CAN 帧字段 

Arb: 仲裁阶段(包括 ID、RTR、RRS、SRR、IDE) 

CTRL: 控制领域(包括 IDE、FDF、DLC、BRS、ESI) 
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BRS:  CAN FD 的比特率开关 

D0...D63: 每个都是 8 位的数据字节 

CRC: 校验和 

EOF: 结束帧 

F：信号 CAN 高（绿色）和 CAN 低（白色），或直接显示差值（蓝色，此

处未显示） 

G：触发位置（红色） 

H：测量光标 C1（黄色）和 C2（橙色）用于时间段测量 

J：H：时间轴网格（水平） 

V：电压轴网格（垂直） 

Stopped/Waiting/Running：触发状态 

C1/C2/Diff：测量光标的相对时间测量值 

 

6.3 调整视图 

功能 Zoom, H-pos, T=0 

通过以下功能，可以调整水平轴（时间轴）上的当前视图。 

 

 

元素 功能 

Zoom 水平放大或缩小。缩放期间的参考点来自 Settings > 

Display trigger position。 
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H-pos 水平移动视图。 

T=0 将视图与触发位置对齐。触发位置根据 Settings > 

Display trigger position 放置在屏幕上 

 

可以参考示波器屏幕顶部的缩略图。 

 

6.4 测量时间段 

功能 Cursor 

可以使用两个光标 C1 和 C2（垂直线）在屏幕上标记时间轴的一部分，以

便测量时间。 

执行以下操作以测量时间： 

1.选择 Cursor > Cursor1 coarse。通过转动拨号盘并最后按下它可以设置

所需时间段的起始点。要微调光标位置，请使用 Cursor > Cursor1 fine。 

提示：如果在测量较大时间同时需要高分辨率，可以在定位光标之前，先

进行放大（Zoom）。这样可以使用更精细的时间分辨率定位光标，在缩小时精

度不会丢失。 

2.使用 Cursor2 重复此过程以设置测量时间段的结束位置，必须位于起始

点的右侧。 

3.在下方状态栏中，读取光标与触发位置（C1，C2）的相对位置和 Diff 时

间段的长度。 
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6.5 自定义视图 

功能 View 

您可以通过选择显示的元素来自定义示波器界面上的信息。这通过显示菜

单中的选项来实现。 

OK 暂时应用选择，Save&OK 永久保存选择。Exit 离开菜单并放弃所做的

更改。 

元素 视图 描述 

CAN-H 上方，绿色的信号 CAN 高信号。 

CAN-L 下方，白色的信号 CAN 低信号。 

CAN-Diff 蓝色的信号 CAN 高和 CAN 低的差分信

号。 

CAN_RxD 上方区域的 Rx 栏 接收信号的位边界和位状

态。 

CAN_TxD 上方区域的 Tx 栏 发送信号的位边界和位状

态。 

Decoder 青绿色的 CAN 帧数据 从 CAN 帧信号解码出的数

据 

Bit fields 黄褐色的 CAN 帧字段描

述 

解码后的 CAN 帧字段的视

图 
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6.6 采样信号 

功能 Single/Stop 和 Run/Stop 

一旦检测到触发事件，样本缓冲区就会开始采集信号。单击 Single 以只进

行一次采样。使用 Run 激活重复采样。使用 Stop 结束每个操作。 

您可以通过 Settings > Trigger 选择使用的触发事件。通过 Settings > 

Pretrigger size 和 Sample buffer size 调整与采样相关的设置。有关这些设

置的详细信息，请参阅第 6.9.3 小节及以下内容。 

 

6.6.1 CAN 信号的解码 

在信号中检测到的 CAN 帧会被自动解码。在网格的上部区域中，显示了

CAN 帧解码后的内容（青绿色：CAN ID，数据长度，以字节为单位，有效载

荷数据）及其位字段（黄褐色）。 

提示：如果未显示此信息，请选择 View 并检查选项 Decoder 和 Bit 

fields。 

如果样本缓冲区中包含多个 CAN 帧，那么位于当前视图中最左侧的帧将被

解码。 

 

6.6.2 修复解码问题 

解码问题 含义 可能的解决方法 

红色的数据 CAN 错误帧 将设备的 CAN 比特率设置为正在连接

的 CAN 总线相同的比特率： 
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-主菜单项 Settings > CAN bitrate 

-可选：Detect CAN bitrate 

没有 CAN 节点发

送 ACK* 

-在 CAN 总线上连接其它 CAN 节点 

-PCAN-Diag 不要使用只听模式 

无数据 没检测到 CAN 帧 使用 H-pos 移动当前视图，直到显示

CAN 帧。 

示波器界面的解码

器元素被禁用 

启用解码器：View > Decoder 

 

*如果在解码时显示帧的字段，则在帧的末尾会显示“noack”错误。 

 

6.7 显示解码后的 CAN 帧的报告 

功能 Report 

通过这个功能，您可以概览解码后的 CAN 帧的属性。 

属性 描述 

配置 这部分显示当前 CAN 设置。可以在主菜单

项 Settings 中更改它们。 

协议 CAN 协议。 

比特率 标称比特率（包括采样点的指示） 

数据场比特率 CAN FD 的数据比特率（包括采样点的指

示） 
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终端电阻状态 CAN 终端电阻的状态。 

终端电阻阻值 测量 CAN 高和 CAN 低之间的总电阻。 

测量 这部分显示在 CAN 帧的解码时产生的测量

值。 

协议 被解码的 CAN 帧使用的 CAN 协议（BRS：

CAN FD 的比特率变换）。 

CAN ID CAN ID。 

数据长度 数据的字节长度。 

（数据） 十六进制格式的数据或“RTR”（远程帧传输

请求）。 

总位数 整个 CAN 帧的位数。 

显性位/隐性位 整个 CAN 帧的显性和隐性位位数。 

填充位 整个 CAN 帧的填充位位数。 

固定的填充位 由 CAN FD 为 CRC 字段预留的填充位位

数。 

错误状态指示 由发送方的 CAN 节点在 CAN FD 帧中设置

的错误状态指示符。 

CRC15，

CRC17，CRC21 

CAN 帧的校验和；根据 CAN 帧类型，使用

不同的 CRC 算法。 

填充位计数器 只有 ISO 格式的 CAN FD 帧：参考填充位

的帧中的额外的检查信息。 

比特率 比特率（包括与设定比特率的偏差） 
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仲裁场比特率/数

据场比特率 

仅具有 BRS 的 CAN FD 帧：标称比特率和

数据比特率（包括与设定比特率的偏差）。 

ACK 场宽度 ACK 位的实际持续时间（所有接收 CAN 节

点的响应）包括与位时间理论上的持续时间

的关系。 

向上偏差越大可能表示响应 CAN 节点的距

离越大或 CAN 节点的延迟处理。 

 

6.8 保存示波器屏幕和样本缓冲区内容 

功能 Export 

根据 Settings > Export，此功能会将以下数据保存到内部存储卡： 

->当前屏幕内容保存为为位图（pict000.bmp） 

->样本缓冲区的内容保存为 CSV 文件（data000.csv） 

->包含报告信息的文本文件（report000.txt） 

这些文件将写入激活项目的目录（Projects> <project name>），稍后可

以通过 USB 线连接到 PC，并从 PC 中读取。从主菜单的下方状态栏中获取激

活项目的名字。 

 

CSV 文件的结构 

CSV 文件包含一些关键的 CAN 参数，以及逐行的文本格式的采样数据。

文件使用分号（;）作为分隔符，可以被导入到任意的电子表格中。 
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6.9 示波器功能的设置 

主菜单项 Scope > Settings 

 

6.9.1 触发 

选择触发信号采样的事件（触发事件）。 

设置 描述 

None 没有触发功能。 

Start of 

Frame 

已识别的 CAN 帧的帧起始。 

End of Frame 已识别的 CAN 帧的帧结束。 

Error Frame CAN 错误帧。 

Free-running 无触发的自由采样，样本缓冲区

会被重复填充。 

CAN ID 带有指定 CAN ID 的 CAN 帧，设

置见 6.9.2 节。 

CAN Rx 

falling 

接收到的 CAN 信号从显性状态

变为隐性状态。 

Bitrate 

Switch 

CAN FD 帧的比特率切换标志。 
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6.9.2 CAN ID 

如果选择 CAN ID 作为触发事件，则使用此处设置的 CAN ID。 

设置 描述 

Frame format CAN ID 的长度（11 位或 29 位）。 

CAN ID 以十六进制格式输入的 CAN ID。 

 

6.9.3 样本缓冲区大小 

更改缓冲区大小以及采样时间。较小的缓冲区对于更快地重复采样运行非

常有用。 

采样时间由样本缓冲区大小和 100 M 采样点/s 的采样率做除法得出的。 

示例：1024 k 采样点÷100 M 采样点/s = 10.24 ms 

 

6.9.4 预触发比例 

一部分信号会显示在触发点之前。这个百分比表示占整个屏幕波形的部

分。可能的比例：10：90，50：50，90：10。 

 

6.9.5 显示触发位置 

在采样过程之后，触发位置（红色垂直线）可以显示在示波器屏幕的左

侧，中间或右侧。此外，此设置也会改变缩放时的参考位置。 
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6.9.6 热键 

在示波器功能中，可以将不同的功能分配给四个热键。 

设置 描述 

None 没有功能。 

Zoom+ , Zoom- 水平放大或缩小。 

H-pos+ , H-pos- 水平移动视图。 

Frame+ , Frame- 跳转到下一个或上一个识别的 CAN

帧。 

Single , Run/Stop 开始采样，一次或重复。 

Report 已解码 CAN 帧的属性概述。 

T=0 将视图与触发位置对齐。 

Save … 

Exit 离开示波器功能。 

Export 保存内部存储卡上的各种数据。 

Import … 

 

6.9.7 视图 

可以通过选择显示的元素来自定义示波器屏幕上的信息视图。 

元素 视图 描述 

CAN-H 上方，绿色的信号 CAN 高信号。 

CAN-L 下方，白色的信号 CAN 低信号。 
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CAN-Diff 蓝色的信号 CAN 高和 CAN 低的差分信

号。 

CAN_RxD 上方区域的 Rx 栏 接收信号的位边界和位状

态。 

CAN_TxD 上方区域的 Tx 栏 发送信号的位边界和位状

态。 

Decoder 青绿色的 CAN 帧数据 从 CAN 帧信号解码出的数

据 

Bit fields 黄褐色的 CAN 帧字段描

述 

解码后的 CAN 帧字段的视

图 

 

6.9.8 导出 

这里确定执行导出功能时将哪些文件写入内部存储卡： 

->Screendump：当前屏幕内容保存为为位图（pict000.bmp） 

->Report：包含报告信息的文本文件（report000.txt） 

->CSV data：样本缓冲区的内容保存为 CSV 文件（data000.csv） 
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7 通过项目配置设备 

主菜单项 Projects 

通过项目设置，PCAN-Diag FD 可以快速适应不同的应用场合。 

一个项目将包含以下元素： 

项目的元素 PCAN-Diag FD 中设置的位置 

通常设置 Settings 

示波器设置 Scope > Settings 

CAN 报文视图设置 CAN Data > CAN Message View > 

Settings 

CAN Data > Transmit Messages > 

Settings 

总线负载和电压测量的显示设

置 

Measurements > Bus Load > Menu > 

Settings 

Measurements > Analog > Settings 

CAN 帧发送列表 CAN Data > CAN Message View 

CAN Data > Transmit Messages 

CAN 帧发送队列 CAN Data > CAN Message View 

CAN Data > Transmit Messages 

信号定义文件 CAN Data > Manage Symbol Files 

启动屏幕（可选） 设备启动时显示（参见第 7.2 节） 

 

使用项目： 
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->使用 PEAK 提供的 Windows 软件 PCAN-Diag FD Editor 在 PC 上创建

和更改项目，然后将其传输到 PCAN-Diag FD 的内部存储卡。 

->可以将任意数量的项目保存到内部存储卡（仅受限于内部存储卡上的剩

余空间）。 

->在使用 PCAN-Diag FD 期间，可以从内部存储卡加载项目。 

->如果内部存储卡上有正在使用的项目的新版本，则在启动 PCAN-Diag 

FD 期间会自动重新加载项目文件。 

->只有选择 Save Project 时，设备内部更改的设置或 CAN 传输列表才会

更改内部存储卡上的附属项目（请参阅下文）。 

 

Load Project 

从内部存储卡中选择一个项目，加载该项目的元素到 PCAN-Diag FD 中。

单击所需项目的名称以加载它。 

注意：从存储卡加载项目时，PCAN-Diag FD 中当前的所有设置，传输列

表和信号文件都将被覆盖。 

默认项目使用 PCAN-Diag FD 的默认设置。 

Save Project 

Save Project as  

将当前的设置，传输列表和信号文件保存到当前加载的项目文件中。或

者，使用不同的名称创建一个新项目。 

Create new Project 
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基于 Default 项目，将在 PCAN-Diag  FD 的内部存储卡上创建一个具有

新名称的新项目。 

Copy Project  

打开保存在 PCAN-Diag FD 上的所有项目的列表，并提供将选定项目保存

为新项目基础的可能性。 

Delete Project 

显示 PCAN-Diag FD 上保存的所有项目的列表，并可以通过单击删除一个

项目。 

Project 

显示激活的项目的名称。 

在启动时，PCAN-Diag FD 检查内部储存卡中的同名工程文件是否比设备

已经加载的版本更新。更新后的工程文件会被自动加载。 

 

7.1 创建和加载项目 

从创建项目到在 PCAN-Diag FD 中使用的过程分为三个阶段： 

->使用 Windows 程序 PCAN-Diag FD Editor 在 PC 上创建一个项目。 

->通过 USB 连接将项目传输到 PCAN-Diag FD 的内部存储卡。 

->在 PCAN-Diag FD 中加载项目。 

 

执行以下操作以创建项目： 
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1.在 PC 上，启动 PCAN-Diag FD Editor（PCANDiagFdEdt.exe）。例

如，您可以在以下目录中提供的 DVD 中找到该程序：/Tools/PCAN-Diag 

FD/Tools/ 

选项卡上会列出项目包含的元素。 

2.使用“保存”将创建的项目保存在数据载体上。如果要添加 CAN 发送列表

并将序列传输到项目，保存是必要的。之后应该使用一个唯一的文件名用作项

目文件名。 

3.在选项卡设置，示波器设置，CAN 数据和测量选项卡上调整应用程序的

设置。有关每个元素的说明，请参阅信息部分。 

4.如果需要，在相应的选项卡上添加一个或多个 CAN 发送列表。使用

Windows 软件 PCAN-View 创建新列表，在发送窗口中列出所需的 CAN 报文

并保存此列表。然后，将其导入 PCAN-Diag FD Editor。 

5.如果要使用传输序列，请将它们输入到 CAN 发送序列列表选项卡。如果

是导入使用 PCAN-View 创建的常规传输列表，CAN 报文的“循环时间”会被解

释为列表中上一条报文的“延迟”。 

6.在信号选项卡上，选择可用于项目的信号文件。 

使用目标格式配置所有信号文件的多路复用器的表示方式： 

通用多路复用器：不同多路复用器的所有信号都显示在公共列表中。 

独立多路复用器：为每个多路复用器列出信号。 

添加请使用导入按钮。 

7.使用保存将创建的项目保存在数据载体上。。 
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执行以下操作将项目传输到 PCAN-Diag FD： 

1.使用提供的 USB 电缆将 PCAN-Diag FD 连接到 PC（另请参见第 10

章）。 

PCAN-Diag Editor 中的“传输”按钮不再变暗，蓝色表示可以进行转移。下

方输出面板会提示已识别出 PCAN-Diag FD。 

2.单击传输并在对话框“选择设备”中检查 PCAN-Diag FD 设备。 

提示：如果多个设备连接到 PC，您可以同时将相同的配置传输到多个

PCAN-Diag 设备。 

使用全选选择所有设备。 

3.单击“确定”。 

项目文件（*.prj）和附属的信号文件，发送列表和发送序列（*.sym，

*.syb，*.xmt，*.xms）会被传输到 PCAN-Diag FD。内部存储卡上使用的目

录是/PCAN-Diag FD/Projects/<项目名称>。 

4.断开 PC 与 PCAN-Diag FD 之间的 USB 连接。 

 

执行以下操作在 PCAN-Diag FD 中加载项目： 

1.在 PCAN-Diag FD 中，选择 Projects > Load Project。 

显示内部存储卡上可用项目的列表以及内部存储卡上的剩余存储空间。 

2.选择之前传输好的项目。 

该项目会被加载并显示为激活的项目。 

激活的项目名称会显示在主菜单的下边缘。 
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提示：您可以在帮助文件中获得有关使用 PCANDiag FD Editor 的更多信

息，该帮助信息通过帮助菜单或 F1 键显示。 

 

7.2 集成替代启动画面 

每个项目都可以有一个独自的启动画面，以便在启动设备时明确说明哪个

项目处于活动状态。这需要将位图文件放入内部存储卡上的相应项目目录中。

如果位图文件不存在，则显示默认的初始屏幕（默认项目）。 

 

 

启动画面的属性 

文件名 Intro_vert.bmp 

内部存储卡上的存储路径 /PCAN-Diag FD/Projects/<项目名

称>/ 

格式 Windows 位图 

分辨率 480 x 800 像素 

颜色深度 24 位 

 

执行以下操作以集成另一个启动屏幕： 

1.在 PC 上创建一个包含表中关键功能的位图文件。 

2.在 PC 和 PCAN-Diag FD 之间建立 USB 连接。 

在 PC 中，PCAN-Diag FD 作为大容量存储设备处理。 
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3.将创建的文件 Intro_vert.bmp 复制到所需的项目目录中（参见表格）。 

4.断开 USB 连接。 
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8 设备的维修功能 

主菜单项 Support 

该页面概述了设备的内部结构。这部分功能通常用于技术支持。 

在这个菜单中的功能可用于维修设备。它们在下面简要描述。 

重要说明：某些功能的误用可能导致设备损坏。 

 

8.1 升级固件 

子菜单项 Update Firmware 

通过我们的技术支持或 PEAK 官网，您可以获取当前版本的固件文件

（*.bin）。 

 

重要说明：在固件更新期间，设备的当前设置将丢失。在更新固件之前，

请确保这些固件存储在内部存储卡上(Project > Save Project )或在 Windows

程序 PCAN-Diag FD 编辑器中作为工程可用。 

 

执行以下操作以更新固件： 

1.确保 PCAN-Diag FD 由外部供电（参考右上方充电指示的插头图标）。 

2.通过 USB 连接到 PC 上，将新的固件文件（*.bin）复制到 PCAN-Diag 

FD 的内部存储卡中，文件路径如下：/PCAN-Diag FD/Firmware/ 

3.在 PCAN-Diag FD 上，选择 Support > Update Firmware。 

4.选择刚刚复制的固件文件。 
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PCAN-Diag FD 会直接开始固件更新。这个过程需要几秒钟。然后 PCAN-

Diag FD 会自动重启。 

5. 如果屏幕上出现相应的提示，请在重新启动前断开 PCAN-Diag FD 的电

源。 

6. 按下 push dial 确认最后的消息。PCAN-Diag FD 关闭。 

7. 用 push dial 再次打开 PCAN-Diag FD。更新过程完成，可以使用该设

备了。 

8.2 启动 Bootloader 

子菜单项 Start Bootloader 

通过一个菜单启动包含基本功能的引导加载程序。 

 

8.3 恢复出厂设置 

子菜单项 Restore Factory Defaults 

所有设置都将重置为当前固件定义的默认状态。 

 

8.4 显示硬件和软件的信息 

子菜单项 Internal Statistics 

显示有关硬件和固件的基本常规信息。 
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8.5 显示目录 

子菜单项 Browse Memory Card 

显示内部存储卡上的目录以查看上面的文件。 

 

8.6 显示电池状态和复位监控 

子菜单项 Battery Status  

该装置包含 6 个镍氢电池，其瞬时电压和温度显示在图形中。 

Battery Current 

显示电池瞬时电流量: 

 负值:电池向设备提供指示电流。 

 正值:电池通过连接的电源进行充电，并指示电流。 

 

Accu Level 

显示电池的瞬时充电水平。 

现在如果电池的充电水平不再显示(也在顶部的状态栏中)，您可以使用

“Reset Charge Level”重置充电水平监控功能。然后，在设备关闭时将电池充

满一次. 

 

Gas Gauge Temp 

电池充电水平的监测模块(“气体表”-水平指示器)测量其环境中的温度，其

独立于电池上的其他温度测量。 
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8.7 校准终端测量 

子菜单 Calibration CAN Termination 

为了正确地确定终端测量的值( 菜单项 Measures > CAN Termination) ,测

量单位必须校准。这就是 PCAN-Diag FD 发货时的情况。在 CAN 终端的测量

屏幕上，显示最后一次校准过程的日期。 

如果显示 No calib 或者测量值无效，此时可以进行校准。 

您需要： 

 1 个电阻 60 ohm ,0.1% 

 自制的 D-Sub 连接器电阻连接在 CAN-Low (引脚 2) 和 CAN-High(引

脚 7)之间，例如通过一个 9 针 D-Sub 母连接器连接。 

 

屏幕上描述了校准过程。 

8.8 管理插件 

如果 PCAN-Diag FD 的功能扩展(外接程序)已经得到您的许可，那么可以

在此管理它们。在 2021 年 07 月 02 日时，还没有外接程序可用。  
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9 查看文件 

主菜单项 View Files 

您可以使用 PCAN-Diag FD 直接查看保存在内部存储卡上的特定文件： 

*.BMP：位图，例如屏幕截图。 

*.txt，*.ini：文本文件，例如报告文档。 

M0：目录结构代表文件在内部存储卡中。 
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10 USB 连接 

主菜单项 USB Connection 

与 PC 的 USB 连接用于访问 PCAN-Diag FD 的内部存储卡。PC 的操作系

统将存储卡绑定到文件管理中，例如，在 Windows 下作为大容量存储设备。 

内存卡 

尺寸 至少 2 GByte 

文件系统 FAT32 

USB 设备的名

称 

PCAN-Diag 

FD 

注意：只有在 PCAN-Diag FD 开启时才能访问存储卡。 

 

10.1 自动 USB 连接 

如果在 Settings 中启用了 USB autoconnect(On)，则内部存储卡将自动

连接到 PC。如果 PCAN-Diag FD 需要存储卡来保存数据或访问数据，则 USB

连接会中断，直到操作完成。 

注意：如果启用该选项，则主菜单中的 USB Connection 条目不可用。 

 

10.2 手动 USB 连接 

如果在 Settings 中禁用了 USB autoconnect(Off)，则内部存储卡通过主

菜单项 USB connection 连接到 PC。离开此功能时，内部存储卡将再次断开连

接。 
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10.3 USB 连接的目的 

 使用提供的 Windows 程序 PCAN-Diag FD Editor（第 7.1 节）将项目

传输到 PCAN-Diag 的存储卡上。 

 访问由 PCAN-Diag FD 创建的记录文件，比特率列表，比特率频率，位

图或 CSV 文件。 

 在项目目录中存储额外的启动画面（第 7.2 节）。 

 将固件更新的*.bin 文件放入目录/PCAN-Diag FD/Firmware/。 

 存储空间随时访问。 

10.4 更新提供的 windows 工具 

内部存储卡包含用于准备 PCAN-Diag FD 项目的软件工具。这些内容由 PEAK - system

定期更新，您可向虹科咨询获得。 

PCAN-Diag FD 的下载包包含所有的组件: 

 PDF 格式的手册和附加信息 

 固件文件 

 设备帮助 

 默认项目 

 PCAN-Diag FD 编辑器 

 PCAN-View 软件 

 PEAK-Converter 软件 
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您可以通过从 PC 到 PCAN-Diag FD(覆盖现有文件)的 USB 连接，将整个 ZIP 包或仅

需要的组件解压缩到内部存储卡的相应文件夹中。 
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11 规格参数 
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